Indice del forum www.zeroshell.net
Distribuzione Linux ZeroShell
 
 FAQFAQ   CercaCerca  GruppiGruppi   RegistratiRegistrati 
 ProfiloProfilo  Log inLog in   Messaggi privatiMessaggi privati 

modifica kerberos 5

 
Nuovo argomento   Rispondi    Indice del forum -> VPN
Precedente :: Successivo  
Autore Messaggio
charneval



Registrato: 03/04/10 16:30
Messaggi: 125
Residenza: perugia

MessaggioInviato: Mar Apr 13, 2010 10:50 am    Oggetto: modifica kerberos 5 Rispondi citando

Credo di aver capito dove sto sbagliando,
in pratica è un problema di server kerberos,
io ho creato un nuovo server locale kerberos e quando vado a creare gli utenti utilizzo la sintassi user@ADALAB.COM,
quando invece creo l'host come mi devo comportare?
dove vado ad inserire il nome del server kerberos? In pratica se inserisco nome e dominio, mi ritrovo nella situazione : host/vpn01@ADALAB.COM.ADALAB.COM oppure in questa host/vpn01@ADALAB.COM.local
a seconda del dominio che vado ad inserire, ma qual'è il procedimento corretto?

In pratica ZS quando va ad autenticare l'utente di openvpn utilizza gli utenti users o gli utenti hosts?
Io vorrei capire la differenza tra i 2 visto che alla fine vanno tutti all'interno del server kerberos 5.

GRAZIE

Andrea
_________________
ADALAB Officina Informatica Perugia
Top
Profilo Invia messaggio privato
Francesco Steno



Registrato: 26/03/10 14:59
Messaggi: 181

MessaggioInviato: Mar Apr 13, 2010 11:24 am    Oggetto: Re: modifica kerberos 5 Rispondi citando

charneval ha scritto:
Credo di aver capito dove sto sbagliando,
in pratica è un problema di server kerberos,
io ho creato un nuovo server locale kerberos e quando vado a creare gli utenti utilizzo la sintassi user@ADALAB.COM,
quando invece creo l'host come mi devo comportare?
dove vado ad inserire il nome del server kerberos? In pratica se inserisco nome e dominio, mi ritrovo nella situazione : host/vpn01@ADALAB.COM.ADALAB.COM oppure in questa host/vpn01@ADALAB.COM.local
a seconda del dominio che vado ad inserire, ma qual'è il procedimento corretto?

nel campo Domain, devi inserire solo il dominio, nel tuo caso ADALAB.COM
e nel campo hostname, devi inserire solo il nome es: host4vpn
Citazione:

In pratica ZS quando va ad autenticare l'utente di openvpn utilizza gli utenti users o gli utenti hosts?
Io vorrei capire la differenza tra i 2 visto che alla fine vanno tutti all'interno del server kerberos 5.

GRAZIE

Andrea
Top
Profilo Invia messaggio privato Invia e-mail
charneval



Registrato: 03/04/10 16:30
Messaggi: 125
Residenza: perugia

MessaggioInviato: Mar Apr 13, 2010 9:35 pm    Oggetto: Rispondi citando

Grazie al prezioso aiuto di Francesco credo di esserci riuscito.
Sto facendo varie prove con alcuni utenti esterni ma ho un problema credo in un client con il sistema Windows 7.
Sembra che appena si autentica il sistema lo disconnette subito.
Ecco il log:
22:19:04 TCPv4_SERVER link local: [undef]
22:19:04 TCPv4_SERVER link remote: 92.245.170.68:52998
22:19:07 92.245.170.68:52998 [bellux@ADALAB.IT] Trying Kerberos 5 (Local KDC) authentication
22:19:08 92.245.170.68:52998 [bellux@ADALAB.IT] Successfully authenticated
22:19:08 92.245.170.68:52998 [bellux] Peer Connection Initiated with 92.245.170.68:52998
22:19:08 92.245.170.68:52998 [bellux] Virtual IP automatically assigned: 192.168.250.1
22:19:10 bellux/92.245.170.68:52998 Connection reset, restarting [-1]
22:19:10 92.245.170.68:52998 [bellux] Client disconnected
22:25:11 Re-using SSL/TLS context
22:25:11 LZO compression initialized
22:25:11 TCP connection established with 92.245.170.68:53006
22:25:11 TCPv4_SERVER link local: [undef]
22:25:11 TCPv4_SERVER link remote: 92.245.170.68:53006
22:25:13 92.245.170.68:53006 [bellux@ADALAB.IT] Trying Kerberos 5 (Local KDC) authentication
22:25:13 92.245.170.68:53006 [bellux@ADALAB.IT] Successfully authenticated
22:25:15 92.245.170.68:53006 [bellux] Peer Connection Initiated with 92.245.170.68:53006
22:25:15 92.245.170.68:53006 [bellux] Virtual IP automatically assigned: 192.168.250.1
22:25:17 bellux/92.245.170.68:53006 Connection reset, restarting [-1]
22:25:17 92.245.170.68:53006 [bellux] Client disconnected




Ho visto che il problema è nella configurazione di openVpn, cioè è come se l'utente non ha i privilegi amministrativi sul device TAP.


Comunque di nuovo grazie del fantastico supporto e spero presto di poter dare aiuti anche da parte mia.

Andrea
_________________
ADALAB Officina Informatica Perugia
Top
Profilo Invia messaggio privato
Francesco Steno



Registrato: 26/03/10 14:59
Messaggi: 181

MessaggioInviato: Mer Apr 14, 2010 1:33 am    Oggetto: Rispondi citando

charneval ha scritto:
Grazie al prezioso aiuto di Francesco credo di esserci riuscito.

Il piacere e' tutto mio Wink
Citazione:

Sto facendo varie prove con alcuni utenti esterni ma ho un problema credo in un client con il sistema Windows 7.
Sembra che appena si autentica il sistema lo disconnette subito.
Ecco il log:
22:19:04 TCPv4_SERVER link local: [undef]
22:19:04 TCPv4_SERVER link remote: 92.245.170.68:52998
22:19:07 92.245.170.68:52998 [bellux@ADALAB.IT] Trying Kerberos 5 (Local KDC) authentication
22:19:08 92.245.170.68:52998 [bellux@ADALAB.IT] Successfully authenticated
22:19:08 92.245.170.68:52998 [bellux] Peer Connection Initiated with 92.245.170.68:52998
22:19:08 92.245.170.68:52998 [bellux] Virtual IP automatically assigned: 192.168.250.1
22:19:10 bellux/92.245.170.68:52998 Connection reset, restarting [-1]
22:19:10 92.245.170.68:52998 [bellux] Client disconnected
22:25:11 Re-using SSL/TLS context
22:25:11 LZO compression initialized
22:25:11 TCP connection established with 92.245.170.68:53006
22:25:11 TCPv4_SERVER link local: [undef]
22:25:11 TCPv4_SERVER link remote: 92.245.170.68:53006
22:25:13 92.245.170.68:53006 [bellux@ADALAB.IT] Trying Kerberos 5 (Local KDC) authentication
22:25:13 92.245.170.68:53006 [bellux@ADALAB.IT] Successfully authenticated
22:25:15 92.245.170.68:53006 [bellux] Peer Connection Initiated with 92.245.170.68:53006
22:25:15 92.245.170.68:53006 [bellux] Virtual IP automatically assigned: 192.168.250.1
22:25:17 bellux/92.245.170.68:53006 Connection reset, restarting [-1]
22:25:17 92.245.170.68:53006 [bellux] Client disconnected




Ho visto che il problema è nella configurazione di openVpn, cioè è come se l'utente non ha i privilegi amministrativi sul device TAP.

In base a cosa partorisci questa affermazione ??
Citazione:




Comunque di nuovo grazie del fantastico supporto e spero presto di poter dare aiuti anche da parte mia.

Andrea

Prova ad aumentare il livello di verbose
verb 7
ed inviaci nuovamente i log....
Un'altra domanda .... non si connette solo usando Windows 7, oppure hai problemi con quell'utente ?
Top
Profilo Invia messaggio privato Invia e-mail
charneval



Registrato: 03/04/10 16:30
Messaggi: 125
Residenza: perugia

MessaggioInviato: Dom Apr 25, 2010 9:16 am    Oggetto: RISOLTO Rispondi citando

Ho risolto il problema, in pratica ho rifatto una nuova configurazione di ZS creando un nuovo profilo dove questa volta sono stato più attento nella compilazione e poi è andato tutto liscio.
E' veramente molto semplice la sua configurazione e con OpenVPN funziona molto bene.

Per openVPN su windows 7 scaricare la corretta versione disponibile in rete:

http://www.fiberworks.com/DNN/Support/OpenVPN/tabid/171/language/en-US/Default.aspx

Grazie a tutti del Forum.....

Andrea
_________________
ADALAB Officina Informatica Perugia
Top
Profilo Invia messaggio privato
Mostra prima i messaggi di:   
Nuovo argomento   Rispondi    Indice del forum -> VPN Tutti i fusi orari sono GMT + 1 ora
Pagina 1 di 1

 
Vai a:  
Non puoi inserire nuovi argomenti
Non puoi rispondere a nessun argomento
Non puoi modificare i tuoi messaggi
Non puoi cancellare i tuoi messaggi
Non puoi votare nei sondaggi


Powered by phpBB © 2001, 2005 phpBB Group
phpbb.it