Indice del forum www.zeroshell.net
Distribuzione Linux ZeroShell
 
 FAQFAQ   CercaCerca  GruppiGruppi   RegistratiRegistrati 
 ProfiloProfilo  Log inLog in   Messaggi privatiMessaggi privati 

ZS 3.3.2 DNS non considera option listen-on

 
Nuovo argomento   Rispondi    Indice del forum -> Segnalazione BUG
Precedente :: Successivo  
Autore Messaggio
zgypa



Registrato: 01/06/12 10:47
Messaggi: 12

MessaggioInviato: Mer Apr 15, 2015 11:05 am    Oggetto: ZS 3.3.2 DNS non considera option listen-on Rispondi citando

Meta: obbligare al DNS ad usare un indirizzo IP specifico quando chiede un domain transfer, o far ascoltare il DNS solo su un indirizzo IP o interfaccia.

(Per esempio, ora come ora, quando fa un zone transfer, sta usando IP dell'interfaccia VPN, perche' si sta collegando al DNS primario via VPN. Quindi, quando faccio cambiamenti su IP delle VPN, devo anche andare ricordarmi di cambiare le configurazioni del DNS primario, altrimenti non riconosce piu' il DNS secondario di ZS)

Soluzione piu' semplice, usare le opzioni: DNS > Options.

Secondo le istruzioni "to set the options you must use the same syntax of the options configurable in the file named.conf of the ISC Bind" e quindi:

Codice:
listen-on [ port integer ] { address_match_element; ... };


Ma quando inserisco un valore, anche del tipo:

Codice:
listen-on { 127.0.0.1; };


ZS continua a rispondere su tutti gli indirizzi IP, e anche i log mostrano che sta ascoltando a tutte le interfaccie e IP, ignorando completamente il comando.
Top
Profilo Invia messaggio privato
Mostra prima i messaggi di:   
Nuovo argomento   Rispondi    Indice del forum -> Segnalazione BUG Tutti i fusi orari sono GMT + 1 ora
Pagina 1 di 1

 
Vai a:  
Non puoi inserire nuovi argomenti
Non puoi rispondere a nessun argomento
Non puoi modificare i tuoi messaggi
Non puoi cancellare i tuoi messaggi
Non puoi votare nei sondaggi


Powered by phpBB © 2001, 2005 phpBB Group
phpbb.it